After testing on the publicly released version of macOS 10.13 High Sierra, all of our Garritan libraries will be compatible with macOS High Sierra when used with ARIA Player 1.872 or later. There are however, some notable exceptions including using the plug-ins in Apple host DAWs.

 

Apple Host Digital Audio Workstations and Garritan Plug-Ins

 

When loading the ARIA Player into a project in a host application created by Apple (such as Logic or Garageband) you may run into an error that states you need an updated version of the plug-in. After closing this error message, the plug-in will not work as expected.

 

This issue has been reported to our development team and a fix is being investigated; however, no timeline is currently available for this fix. To be kept up-to-date on information about this issue, please click the green Follow button at the bottom of this article to subscribe to it.

 

CFX Concert Grand and CFX Lite players

 

CFX Concert Grand and CFX Lite each have their own players separate from the ARIA Player that have additional controls and are dedicated to the libraries. Those players are unable to use the preferences dialog box without crashing. While it may be possible to load sounds and use the player, we do not expect the key component of preferences to operate as expected.

 

Our Garritan team has been informed of the issue and is investigating the possibility of a solution; however, no timeframe for a solution has been set. If you would like to be updated when more information is available, please click the green Follow button to subscribe to updates to this article.

 

In the meantime, it is possible to try using the CFX libraries through the ARIA Player. If you do not have the ARIA Player installed, you will need to install it and run the installer for your CFX library once more for it to appear. This limits the normally available controls, but gives you access to global preferences.