New post

Seemingly out of the blue, my Logic Pro X files created with this piano have stopped opening.  When I try to open one, Logic crashes and tells me it unexpectedly quit while using Aria plugin.  Here are the steps I've taken to try and resolve, but have not had any luck:

First, I uninstalled Aria Player per these Mac instructions:

I emptied my trash bin, then I re-installed ARIA Player 1.959 for Macintosh.  I tried opening Logic and it opened, but told me that I needed to update my Aria Engine because my project had been created with a newer version.  So, I went here: and got the 1.967 version of the engine.  Before running Logic again, I opened the standalone Aria Player to confirm the new engine was in place and it shows Player 1.959 and Engine 1.967, so all is well.  But, I tried opening Logic and again, it crashed.

I can work around this problem, by opening Logic in safe mode (CTRL + Open) which disables all my plugins.  But if I try to re-activate them within the project, it crashes.  HOWEVER, if I open in safe mode, close the project that I was working on and open a blank project, THEN I can turn on my plugins (disable/enable Core Audio) and then I can also open CFX Grand Piano and it works fine and continues to work fine until I close.  But then when I shut down Logic and try to re-open that same file, crash.

Any ideas?

OS Catalina v10.15.7
Logic Pro X 10.6.1
Aria Player 1.959
Aria Engine 1.967
iMac 27", 2017 (4.2 Ghz, Quad i7, 32 GB RAM and nearly 2TB free disk space)

I have a trouble ticket in as well, but thanks for any ideas.  I've tried uninstalling/reinstalling Aria Player twice.  Should I also try and uninstall the Garritan sample library?


Date Votes

No: don't re-install the library. Firstly, there's a problem with the CFX installer on Catalina.

Secondly, re-installation is over-rated as a fix. The files that get installed are usually read-only once in place, and so unless you've gone in and deliberated deleted /Library files, they will still be there.

It can be useful to install multiple products in a particular order, e.g. Garritan after Finale,  but If you re-installed ARIA once, then re-installing it again isn't going to re-install it better or harder. 

I'm using Logic with ARIA on Mojave and Big Sur, (missing out Catalina, admittedly), so there's nothing inherently wrong with that setup. However, the CFX piano has its own plug-in, I believe, and that might have its own version of ARIA inside it. 

Do you have any other third-party plug-ins? What might have changed on your computer at the time things stopped working? If the CFX piano plug-in worked with Logic previously, then I'd look for some other cause, beyond the plug-in itself. 

Comment actions Permalink

Thanks for the input.  I have plenty of third-party plug-ins running, but to my recollection I didn't install or update any in correlation with this problem showing up.  The only thing I did around the time this started crashing, was that I moved some of my other instrument libraries from my internal drive to an external, but I didn't even touch CFX during that process, because I intended to leave CFX on the internal drive.  Go figure, the one I left alone is the only one screwed up!  This is the only plugin I have that uses Aria Player.  

Comment actions Permalink

Please sign in to leave a comment.