New post

Hello! I'm on a Macbook M1, mac OS 12.4 Monterey

I'm unable to install Garritan CFX Concert Grand on my Macbook. Specifically, I'm unable to install the sample files. During installation, I get errors about MD5 checksum failing multiple times, and so the copied files get deleted. I've already tried the following, none of it fixed my issue:
1. I've tried deleting the downloaded zip (~14GB), and re-downloading it, in case there is some kind of corruption.
2. I've tried installing the compact version instead.
3. I've looked at and tried to tweak the plist file to point to the sample files that came with the installer. That did not work, and I reverted the plist changes.
4. I've tried manually copying (using a script) the sample files that came with the installer into the appropriate paths under /Users/Shared/CFX_Samples/ (the standard Mac directory for the CFX sample files), with appropriate suffixes and ending with .audio extension. This makes the player's errors go away since it's able to find the files in the right places, but I only get a static hissing sound when I actually playback my MIDI file in Logic with Garritan plugin. My suspicion is that it's not enough to just copy the files, and some decompression of the flac samples may be necessary as well.

I'm attaching a screenshot. I see this kind of MD5 error happen 9 times, which suggests that it's happening for each of the 9 folders in the SamplesData directory that came with the installation. When I catch it in the act, and list one of the directories, I see a combination of .data files: some are owned by me, and dated at March 2 2021, and have a non-zero byte size. Others are owned by root, are dated at Jun 4 (today), and have a 0-byte size. I assume those are the problem, as the path in the MD5 checksum failure is always one of these 0-byte files.

Thanks in advance!

1 comment

Date Votes

Another observation I've made: the set of files which end up being 0-bytes is non-deterministic. So if I re-run the installer multiple times, it's always different random files which end up being 0-bytes and owned by root. This is certainly not an issue with corrupted files, but it seems like there's some bug in the copying process...

Comment actions Permalink

Please sign in to leave a comment.