New post
Avatar
0

Hi guys. I've been using the same folder location and same default document name for many years. However, I recently got a new 2019 MacBook Pro 16" with Catalina and my default document usually doesn't load i.e. most of the time, a different default document loads at startup (i.e. a document without libraries). What's weird is that SOMETIMES the correct default document loads!?!

I've checked my old MacBook Pro and the folder/file locations and name of the default document are identical to the Preferences settings in my Catalina installation. However, this incorrect default document behaviour is only present in my Catalina installation. I can press CMD+N to correctly load my preferred default document but this problem shouldn't be occurring. I've tried resetting my Finale Preferences and reconfiguring these, but the problem persists.

Do you have any idea what is going on? This is driving me nuts.

Regards
Gary

5 comments

Date Votes
Avatar
1

No idea — I'm not seeing this. Unless someone knows the issue and chimes in, I would use the Submit a request link at the top of the page.

 

The intermittent nature makes me wonder if it's a corrupt system path. The MacOS will work around these on the third try but they can be rebuilt by doing a Safe Boot. Shut down, boot with the Shift key held down. Log into your User account when prompted. Wait till your desktop icons have rebuilt. Reboot and you're done. This can take a long time so be patient. 

 

You may find that some apps will launch more quickly afterward. If you have any generic alias icons, they will be fixed (and were a symptom of corrupt pathways). This tool has been part of the OS since System 5 or earlier (when it was called Rebuild Desktop) but I've fixed a number of annoying issues in High Sierra, Mojave and Catalina with a Safe Boot — weird as that sounds... I now do it after an OS update or major software installation.

Comment actions Permalink
Avatar
0

Hi Mike

Thanks for replying.  I've done what you suggested re. Safe Boot but there's no change in Finale's behaviour.  Since I originally posted, I've realised that the default document Finale is loading at Startup is a "Document without libraries" i.e. File\New\Document Without Libraries.

I've submitted a ticket and will see what happens.

Thanks!

Gary

Comment actions Permalink
Avatar
0

Ok, it looks like I've solved the problem.  In macOS System Preferences\General, I checked the box titled "Close windows when quitting an app" and the correct default document now loads at Startup.  

I'd noticed that if I closed all Finale docs before quitting the app, the correct default document would load.  Conversely, if I didn't close all Finale docs (including the wrong default document) when quitting, the wrong new document (the one without libraries) would load at Startup.  I then did a Google search for the System Preference option that tells apps to either load/not load documents present before the app was last closed and changed this setting.  Voila, Finale now works properly.  Weird.

Comment actions Permalink
Avatar
0

Good that you found it. 

 

This has been a feature of the Mac OS since ... heck, it’s been so long that I don’t remember. Sometimes, it’s so easy to overlook the simple stuff. Lord knows, I do that often enough.

Comment actions Permalink
Avatar
0

Yeah, I knew this was a feature but it shouldn’t affect Finale’s default new document behaviour. This sounds like a Finale bug to me.

Comment actions Permalink

Please sign in to leave a comment.